Opened 6 years ago

Closed 6 years ago

#148 closed usability (Duplicate)

.xinitrc / xterm starting problem - possible timing or interrupt bug

Reported by: weinberger@… Owned by: jeremyhu@…
Priority: Important Milestone:
Component: X11.pkg Version: 2.3.0 (xserver-1.4.2-apple5)
Keywords: Cc:

Description

I used to always start x11 (v 2.1.1 and earlier) with X11 in the dock and I had a .xinitrc that opened 8 xterms with various names. That is, my .xinitrc looks like:

quartz-wm &
xterm -geometry 80x30 -sb -sl 1024 -T "xterm 1" -n "xterm 1" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
xterm -geometry 80x30 -sb -sl 1024 -T "xterm 2" -n "xterm 2" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
xterm -geometry 80x30 -sb -sl 1024 -T "xterm 3" -n "xterm 3" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
xterm -geometry 80x30 -sb -sl 1024 -T "xterm 4" -n "xterm 4" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
xterm -geom 80x50 -sb -sl 1024 -T "iraf" -n "iraf" &
xterm -geom 80x30 -sb -sl 1024 -T "urania" -n "urania" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
xterm -geom 80x30 -sb -sl 1024 -T "idl" -n "idl" -fn "-b&h-lucidatypewriter-bold-r-normal-sans-14-140-*-*-*-*-*-*" &
exec xterm -geometry 80x50+0+0 -name login

When I "upgraded" from 2.1.1 to 2.3.0, the xterms I call for in my .xinitrc stopped showing up reliably. I get some but not all of the ones
I call and the ones I do get show up in random order (not very useful if you want to always use command-1 to get the same window).

I also tried an alternate way to start my xterms. I made an executable script of all those xterm commands and put it in my dock. Then I launched the script from the dock. This opens Terminal which then launches x11. I get process numbers in the Terminal for each of my xterm calls, but I still get only some of the xterms to appear in x11 and again the ones that do appear are random. A 'ps aux' shows the processes of the non-appearing xterms, which then do not even die when I quit x11 (I can kill them from the Terminal).

Change History (1)

comment:1 Changed 6 years ago by jeremyhu@…

  • Resolution set to duplicate
  • Status changed from new to closed

This is a known kernel bug and not specific to X11 or xterms.

Note: See TracTickets for help on using tickets.