Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#222 closed crash (Duplicate)

GLX: support fbconfig

Reported by: derrick22@… Owned by: gstaplin@…
Priority: Important Milestone: 2.4.0
Component: GLX Version: 2.3.1 (xserver-1.4.2-apple17)
Keywords: Cc: brad@…, davelov@…, jimumbra@…

Description

According to a closed ticket http://xquartz.macosforge.org/trac/ticket/122 the GLX_SIGX_fbconfig issue has been fixed by a RC of 2.3.2. Just to be sure, I have tried all the RCs though the current build of RC5. There is still an issue. I get

err:wgl:has_opengl glx_version is 1.2 and GLX_SGIX_fbconfig extension is unsupported. Expect problems.

I have verified with glxinfo that I do have GLX_SIGX_fbconfig available.

Change History (12)

comment:1 Changed 6 years ago by jeremyhu@…

  • Owner changed from jeremyhu@… to gstaplin@…

comment:2 Changed 6 years ago by jeremyhu@…

  • Component changed from X11.pkg to xserver
  • Milestone changed from 2.3.2 to OpenGL.framework DRI
  • Version changed from dev (xorg-server-1.5-apple) to 2.3.1 (xserver-1.4)

comment:3 Changed 6 years ago by brad@…

  • Cc brad@… added

Cc Me!

comment:4 Changed 6 years ago by davelov@…

  • Cc davelov@… added

Cc Me!

comment:5 Changed 6 years ago by davelov@…

I'm confused regarding this bug's status. According to the roadmap this bug is included in in milestone "OpenGL.framework DRI". However thisWineHQ forum page suggests that this bug is included in milestone 2.4. Yet still the previously closed listing for this problem, Bug122, states it was fixed in 2.3.2 and the release version of both 2.3.2 and 2.3.1 report the same error. I've even tried using the most recent release of the 2.4 alpha and it also fails (though with a different error message so I do not know if it is a different error or not). Can someone just say what the actual status of this is, if anybody knows of course.

comment:6 follow-up: Changed 6 years ago by jeremyhu@…

2.4.0_alpha1 did not have the GLX updates. 2.4.0_alpha2 will. Please try 2.4.0_alpha2 when it is released (this weekend perhaps).

comment:7 Changed 6 years ago by davelov@…

Excelent. Thanks for clearing that up.

comment:8 Changed 5 years ago by jimumbra@…

  • Cc jimumbra@… added

Cc Me!

comment:9 in reply to: ↑ 6 Changed 5 years ago by jimumbra@…

Replying to jeremyhu@…:

2.4.0_alpha1 did not have the GLX updates. 2.4.0_alpha2 will. Please try 2.4.0_alpha2 when it is released (this weekend perhaps).

Where do we download the alphas.... All i see is the releases link which doesn't contain 2.4.x
thank you

comment:10 Changed 5 years ago by jeremyhu@…

  • Resolution set to duplicate
  • Status changed from new to closed

Subscribe to the xquartz-dev mailing list. Visit the xquartz.macosforge.org/downloads

comment:11 Changed 4 years ago by jeremyhu@…

  • Component changed from xserver to GLX

comment:12 Changed 4 years ago by jeremyhu@…

  • Milestone changed from OpenGL.framework DRI to 2.4.0
Note: See TracTickets for help on using tickets.