Ticket #253 (closed usability: fixed)

Opened 5 years ago

Last modified 5 years ago

Spaces broken with 2.3.3_rc4

Reported by: giroux@… Owned by: jeremyhu@…
Priority: Nice to Have Milestone: 2.3.3
Component: xserver Version: dev (xorg-server-1.4-apple)
Keywords: Cc:

Description

Here's the scenario:

  • I have all my X11 windows in space 1;
  • I go to some other app in another space;
  • I switch back to X11 with either cmd-tab or the dock, I get my X11 windows in the current space instead of going back to space 1.

Change History

comment:1 Changed 5 years ago by jeremyhu@…

Are your windows override-redirect? This should only be happening with windows that are override-redirect (like menus and tooltips).

http://cgit.freedesktop.org/xorg/xserver/commit/?id=2c03a63ff6855272d587b4972a67f64115a1ce4c

comment:2 Changed 5 years ago by jeremyhu@…

Yeah, I can't reproduce this.

  • Move to space 4
  • Open Mail.app
  • Move to space 1
  • Open X11.app
  • Create 2 xterms in space 1
  • Click on Mail in the dock, we move to space 4
  • Click on X11 in the dock, we move to space 1

comment:3 Changed 5 years ago by jeremyhu@…

  • Status changed from new to closed
  • Resolution set to fixed

I was able to reproduce it and a fix will be in the final 2.3.3

Note: See TracTickets for help on using tickets.