Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#28 closed usability (Duplicate)

restoring minimized X11 window does not switch to X11 app

Reported by: clinstid@… Owned by: bbyer@…
Priority: Nice to Have Milestone:
Component: xserver Version:
Keywords: minimize Cc:

Description

The setup for this is pretty simple:

  1. Start X11
  2. Open an X11 application (an xterm will work)
  3. Minimize the X11 window
  4. Switch to another application
  5. Click on the minimized X11 window in the dock to restore it

At this point, the X11 window will be restored and even on top, but the application will still be whatever you switched to after you minimized the X11 window.

I believe the component for this is the xserver, but I'm new at this (my first ticket, yay!), so sorry if that's wrong. :)

Change History (1)

comment:1 Changed 7 years ago by jeremyhu@…

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of the quartz/x11 event synchronization bug. I'll add you to that one's CC.

Note: See TracTickets for help on using tickets.