Opened 5 years ago

Closed 5 years ago

#363 closed usability (Cannot Reproduce)

switching away from X11 while in fullscreen mode hides the window

Reported by: dpranke@… Owned by: jeremyhu@…
Priority: Nice to Have Milestone: 2.5.1
Component: xserver Version: 2.4.0 (xserver-1.5.3-apple14)
Keywords: Cc:

Description

I'm not sure if this is a bug or not, but I'll describe what currently happens and what I'd like to happen.

If I launch X11 (either 2.3.x or 2.4.0) and enable full screen mode, then I get a full screen window and the Mac menu bar disappears as per plan.

If I enable Mac hotkeys, and then switch to a different Space using the hotkeys, then the X window hides. instead of being sent to the back.

If I then switch back using the hotkeys, then I get to the right Space but the window stays hidden, and I have to explicitly switch back to the app using cmd-Tab.

I am attempting to use Spaces to get a "virtual KVM" like effect between a Mac box, and Windows box, and a Linux box. I use RDC to connect to the windows box, and NX to connect to the Linux box. RDC does what I want in this case. Is it possible to get X11 to send the window to the back instead of hiding it?

Change History (3)

comment:1 Changed 5 years ago by jeremyhu@…

  • Milestone set to 2.5.1
  • Status changed from new to assigned
  • Version set to 2.4.0 (xserver-1.5)

I have no idea what you mean by "send the window to the back" ... which window are you talking about? The X11 root window? What would happen if it was sent to the back... the back of what?

When you switch spaces, the windows should be left on the previous space. When you switch back, they are there.

Nothing is ever "hidden" or "moved to the back"

Please clarify what you expect to happen and what you are seeing now.

comment:2 Changed 5 years ago by jeremyhu@…

Can you please clarify what the problem is. Also, please make sure the problem is in 2.5.0.

comment:3 Changed 5 years ago by jeremyhu@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

No response, and I cannot make sense of the reported problem. If you ever surface, please ask me to reopen this issue and answer my questions above.

Note: See TracTickets for help on using tickets.