Opened 8 years ago

Closed 8 years ago

Last modified 2 weeks ago

#39 closed usability (Duplicate)

Error when i try to run a opengl program on wine

Reported by: borgespedro@… Owned by: bbyer@…
Priority: Important Milestone: 2.2.0
Component: xserver Version: 2.1.1 (xserver-1.3.0-apple5)
Keywords: darwine x11 bug Cc: sscanner@…

Description

When I try to run a windows programm on wine with opengl support on bash I get this:


macbook:Counter-Strike 1.6 highvolt$ DYLD_FALLBACK_LIBRARY_PATH=/usr/X11/lib wine cstrike.exe

X Error of failed request: BadValue (integer parameter out of range for operation)


Major opcode of failed request: 128 (Apple-DRI)


Minor opcode of failed request: 2 ()

Value in failed request: 0x3f

Serial number of failed request: 17

Current serial number in output stream: 17

Thanks in advance

Change History (52)

comment:1 Changed 8 years ago by borgespedro@…

I forget to say that I am running wine 0.9.51 on Mac os x Leopard 10.5.1

comment:2 Changed 8 years ago by borgespedro@…

  • Priority changed from major to blocker
  • Type changed from crash to usability

comment:3 Changed 8 years ago by jeremyhu@…

  • Milestone set to 2.2.0
  • Priority changed from blocker to major

comment:4 follow-up: Changed 8 years ago by jeremyhu@…

Why do you need DYLD_FALLBACK_LIBRARY_PATH=/usr/X11/lib? Where are you getting wine from? macports? fink? compiled yourself? what is the output of 'otool -L <path to wine>'?

Honestly, getting wine working is a low priority at this point because of other issues still around, but it is something that should work.

comment:5 in reply to: ↑ 4 Changed 8 years ago by borgespedro@…

I need to do DYLD_FALLBACK_LIBRARY_PATH=/usr/X11/lib because if i don't do anything i get

err:wgl:X11DRV_ChoosePixelFormat No libGL on this box - disabling OpenGL support !
err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter

I compiled wine by myself.
The output of 'otool -L /usr/local/bine/wine' is
wine:

@executable_path/../lib/libwine.1.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.0.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

I'm new on mac os x but i have some experience compiling programms on linux.

Thanks for trying to help me.

comment:6 Changed 8 years ago by jeremyhu@…

Ok, I'm guessing wine tries to dlopen libGL from the wrong location there...

As for wine... like I said... this is something that is pretty far off, so I'll leave the bug open, but I doubt we'll be able to tackle it for a few months atleast. You might have better support from a wine mailing list

comment:7 Changed 8 years ago by borgespedro@…

Ok.
Thanks, any way

comment:8 Changed 8 years ago by jeremyhu@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #51 which contains patch

comment:9 Changed 3 months ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:10 Changed 3 months ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:11 Changed 3 months ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:12 Changed 2 months ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:13 Changed 2 months ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:14 Changed 2 months ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:15 Changed 2 months ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:16 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:17 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:18 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:19 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:20 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:21 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:22 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:23 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:24 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:25 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:26 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:27 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:28 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:29 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:30 Changed 7 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:31 Changed 6 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:32 Changed 6 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:33 Changed 6 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:34 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:35 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:36 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:37 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:38 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:39 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:40 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:42 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:41 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:42 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:43 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:44 Changed 4 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:45 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:46 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:47 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:48 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

comment:49 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:50 Changed 3 weeks ago by sscanner@…

  • Cc sscanner@… removed

Cc Me!

comment:51 Changed 2 weeks ago by sscanner@…

  • Cc sscanner@… added

Cc Me!

Note: See TracTickets for help on using tickets.