Opened 4 years ago

Closed 4 years ago

#408 closed usability (Behaves Correctly)

Xmodmap settings get reset...

Reported by: doh123@… Owned by: jeremyhu@…
Priority: Nice to Have Milestone: 2.5.1
Component: xserver Version: 2.5.0 (xserver-1.7.6)
Keywords: Cc:

Description

When starting up X11, before typing any thing in any X app (xterm or whatever, happens with Wine too), I can set xmodmap (in a startup script) and remap some keys. These keys show as changed just fine... As soon as I actually have X11 as the active app and press any key (a few seconds later, or even let it set several minutes)... it resets everything back to defaults and just loads the ~/.Xmodmap file, and loses what was set manually in the startup script. Easily reproducible, in 2.5.0 and in the devel version off macports I have installed. Highly annoying...

I've only tested and found this off remapping the Alt buttons to actually be Alt buttons... a start up script that launches X and programs uses xmodmap to remap Alt to be Alt keys, and they show up as such, but as soon as I type anything in X11, they switch right back to Mode_switch... switching them again after that sticks, it only resets the first time anything is pressed after being started.

Change History (4)

comment:1 Changed 4 years ago by jeremyhu@…

  • Resolution set to behaves correctly
  • Status changed from new to closed

This is by design. Anything you want to customize should go in .Xmodmap ... as for alt / mode_switch, I suggest you just use the X11 preference for that rather than .Xmodmap (input tab).

comment:2 Changed 4 years ago by doh123@…

well, I'm sure there is a reason for that, but it causes issues if you use multiple X servers and you don't want them all to have the same ~/.Xmodmap file... so I'll have to script out editing that one file for every one which can lead to many issues when they have the possibilty of running at the same time. Using the preference is fine for Alt, thanks for adding that, but it won't help for other remappings.

comment:3 Changed 4 years ago by mrdomino@…

  • Resolution behaves correctly deleted
  • Status changed from closed to reopened

This isn’t really ideal. I’d like to use the same dotfiles for Mac and Linux machines, and so far this is the only case in which I can’t without maintaining multiple branches. At the least, this behavior should be user-configurable in some way.

comment:4 Changed 4 years ago by jeremyhu@…

  • Resolution set to behaves correctly
  • Status changed from reopened to closed

That's unrealistic. You can't even use the same .Xmodmap file for different linux machines with sufficiently different keyboards. If you want to do something like that, you need to use ~/.xinitrd.d and use different files...

Note: See TracTickets for help on using tickets.