Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#450 closed usability (Cannot Reproduce)

WIN-key combos impossible with XQuartz

Reported by: deadballo@… Owned by: jeremyhu@…
Priority: Important Milestone:
Component: xserver Version: 2.5.3 (xserver-1.8.2)
Keywords: Cc:

Description

The command key is properly recognized as the WIN key in my KDE apps when pressed on its own, but it cannot be used in combination with other keys.

For example: WIN-Y should be possible by pressing command-Y. If I press command WIN is registered, but when I press Y the WIN key is released and only Y is registered.

This is a bit if a bugaboo for me since I use custom WIN keys a lot. I don't know if others even use WIN keys, but it would become more of an unsolvable problem if using, for example, KRDC.

Change History (4)

comment:1 Changed 4 years ago by jeremyhu@…

There is no "WIN" key in X11. My guess is that they're calling Meta win.

Can you try reducing this problem. Use 'xev' or 'xinput print keyboard'

This sounds like something that was fixed ages ago. What does 'X11->About X11' report for the version?

comment:2 Changed 4 years ago by deadballo@…

Well, like I selected in the bug report, I'm using XQuartz 2.5.3.

xev shows the same error I'm reporting: The Meta keys cannot be chorded with other keys.

This bug exists in 2.5.3

comment:3 Changed 4 years ago by jeremyhu@…

  • Resolution set to worksforme
  • Status changed from new to closed

Nobody else seems to be experiencing this problem. You need to provide more info. Can you please try with a fresh user account? Join the x11-users mailing list to get more eyes and help.

comment:4 Changed 4 years ago by deadballo@…

I have tested the latest version and it appears to work fine. I was able to chord with the Meta key.

Note: See TracTickets for help on using tickets.