Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#474 closed crash (Duplicate)

Frequent crashes with XQuartz on OS X

Reported by: amicitas+macosforge@… Owned by: jeremyhu@…
Priority: Expected Milestone: 2.6.3
Component: xserver Version: 2.6.1 (xserver-1.9.5)
Keywords: Cc:

Description

I have been experiencing semi-frequent crashes with XQuartz for many months now. These crashes happen for me several times a week.

I have been hoping that I would be eventually be able to pinpoint the cause, but so far I am still unsure of what actions cause the crashes.

The crashes are of two types:

  1. Complete crash, XQuartz closes. This type of crash sometimes (but not always) happens when I try to open a new instance of emacs.
  1. All XQuartz windows become unresponsive. In this case I can still use the menu buttons, but I cannot get any response from open windows or start new xterm windows. This type of crash sometimes (but not always) seems to be related to switching networks.

I typically use XQuartz with several xterm windows and one or more emacs windows (currently version 23.3.1). I have the "Authenticate connections" option turned off.

OS X 10.6.7
XQuartz 2.6.1

Attachments (3)

2011-03-18_xquartz_crash_report.txt (35.2 KB) - added by amicitas+macosforge@… 4 years ago.
Crash report 2011-03-18
2011-03-17_xquartz_crash_report.txt (34.2 KB) - added by amicitas+macosforge@… 4 years ago.
Crash report 2011-03-17
2011-04-07_xquartz_crash_report.txt (34.2 KB) - added by amicitas+macosforge@… 4 years ago.
Crash report 2011-04-07

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by amicitas+macosforge@…

Crash report 2011-03-18

Changed 4 years ago by amicitas+macosforge@…

Crash report 2011-03-17

Changed 4 years ago by amicitas+macosforge@…

Crash report 2011-04-07

comment:1 Changed 3 years ago by amicitas+macosforge@…

Crashes are still frequent for me with XQuartz 2.6.2; I have had at least four or five crashes in the last 2 days. At one point the crash happened after X11 was open for ~2 minutes, with no changes in network settings.

comment:2 Changed 3 years ago by jeremyhu@…

  • Component changed from X11.pkg to xserver
  • Milestone set to 2.7.0
  • Priority changed from Not Set to Expected
  • Status changed from new to assigned

Can you attach new crash reports? Can you tell me how to reproduce it? I haven't seen any X11 crashes for quite a while, so please let me know how you're triggering them.

comment:3 Changed 3 years ago by amicitas+macosforge@…

I'll attach a few new crash reports as they come up, along with descriptions of what I was doing. Unfortunately I don't know how to trigger the crashes; so far I have not been able to make out a pattern. They often happen without any particular action on my part (at least as far as I have been able to tell).

comment:4 Changed 3 years ago by jeremyhu@…

These may have been memory smashers related to http://xquartz.macosforge.org/trac/ticket/463 ... can you please try the fix described in that ticket and let me know if it addresses the problem for you? Do you ever attach or remove external displays from your system?

comment:5 Changed 3 years ago by amicitas+macosforge@…

I do indeed attach and remove external displays several times a day. I'll give that fix a shot and see if it helps. Given that I am traveling, I probably won't have an update for a few weeks (though if I don't have any crashes during that time, that will help pinpoint the problem on the external monitor as well).

comment:6 Changed 3 years ago by jeremyhu@…

  • Resolution set to duplicate
  • Status changed from assigned to closed

Marking as dupe of #463 due to your external display use. Please use the fix there.

comment:7 Changed 3 years ago by jeremyhu@…

  • Milestone changed from 2.7.0 to 2.6.3

There was one more crasher that isn't mentioned in the fix for #463. Please verify with 2.6.3_rc1 or later.

comment:8 Changed 3 years ago by amicitas+macosforge@…

I have just updated to 2.6.3_rc1. I will report here if I have any further crashes.

Note that while traveling for the last two weeks I did not have a single X11 crash. As soon as I returned and plugged in my external monitor (before upgrading to 2.6.3), a crash happened. This is certainly in line with the discussion above.

Note: See TracTickets for help on using tickets.