Opened 3 years ago

Closed 3 years ago

#518 closed crash (Invalid)

won't run

Reported by: jeffrey.denison@… Owned by: jeremyhu@…
Priority: Important Milestone: 2.6.3
Component: xserver Version: 2.6.1 (xserver-1.9.5)
Keywords: Cc:

Description (last modified by jeremyhu@…)

HI,
Running 10.5.8 on a 1.8MHz G5.
Apple's X11.app froze on me & I could never get it to work right so I manually removed it. Reinstalled it from disk then installed 2.6.1 binary. I got errors re no socket available. Ran postinst_sl.sh

Terminal out now:

G5:~ jeffrey$ startx
font_cache: Scanning user font directories to generate X11 font caches
font_cache: Updating FC cache

Xquartz: Unable to locate waiting server: org.x.X11
Xquartz: X11.app = /usr/X11/X11.app/Contents/MacOS/X11
Xquartz: Starting X server: /usr/X11/X11.app/Contents/MacOS/X11 --listenonly
X11.app: main(): argc=2
	argv[0] = /usr/X11/X11.app/Contents/MacOS/X11.bin
	argv[1] = --listenonly
Waiting for startup parameters via Mach IPC.
X11.app: No launchd socket handed off, unsetting DISPLAY
X11.app: do_start_x11_server(): argc=4
	argv[0] = /usr/X11/bin/X
	argv[1] = :0
	argv[2] = -nolisten
	argv[3] = tcp
Xquartz starting:
X.Org X Server 1.9.5
Build Date: 20110317
Thread Assertion Failed: self=Unknown Thread, expected=Xserver Thread
xprFrame.c:xprInit:484
0   X11.bin                             0x000157e4 spewCallStack + 44
1   X11.bin                             0x0001a4f0 xprInit + 72
2   X11.bin                             0x0001b944 QuartzModeBundleInit + 1696
3   X11.bin                             0x00012c9c QuartzSetupScreen + 52
4   X11.bin                             0x0000e700 OsVendorInit + 708
5   X11.bin                             0x000d4148 AddScreen + 388
6   X11.bin                             0x0000e9cc InitOutput + 188
7   X11.bin                             0x000ca024 dix_main + 624
8   X11.bin                             0x00014518 QuartzInitServer + 268
9   libSystem.B.dylib                   0x930120c8 _pthread_start + 320
font_cache: Done
/usr/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1

thanks

Change History (1)

comment:1 Changed 3 years ago by jeremyhu@…

  • Description modified (diff)
  • Milestone set to 2.6.3
  • Resolution set to invalid
  • Status changed from new to closed

You did something wrong.

1) The output shows '/usr/X11/X11.app' ... which should not exist either with Apple's X11 or with XQuartz

2) You should start X11 by just running an X11 application (xterm) or double clicking X11.app, NOT by running startx

Do the following:

sudo rm -rf /usr/X11 /usr/X11R6 /Applications/Utilities/X11.app

Install XQuartz-2.6.3 for Leopard

Note: See TracTickets for help on using tickets.