Opened 3 years ago

Closed 3 years ago

Last modified 7 months ago

#543 closed usability (Cannot Reproduce)

2.7.1_rc2 initially xterm has focus but doesn't receive keys until after mouse click anywhere

Reported by: x11@… Owned by: jeremyhu@…
Priority: Nice to Have Milestone: 2.7.2
Component: xserver Version: dev (master)
Keywords: focus Cc:

Description

upon initially starting xquartz (and starting fullscreen
with command-option-a because it didn't enter fullscreen
mode automatically), moving the mouse pointer over
an xterm (with focus following the pointer), the xterm
looks like it has keyboard focus but keys that are typed
don't appear in the window until after i have first
"clicked the mouse" somewhere. i don't mean clicking in
the window. the click can happen in the root window and
when i move the pointer back to the xterm any keys typed
are received by the xterm. macosx-10.6.8.

this behaviour is similar to what i see in other versions
when i leave the preference dialog open, then go back to
full screen mode - i have to click somewhere before keys
are received by xterm but with this version it happens on
startup without the presence of the preferences dialog. i
don't know if these are connected in any way.

Change History (3)

comment:1 Changed 3 years ago by jeremyhu@…

  • Milestone set to 2.7.2
  • Priority changed from Not Set to Nice to Have
  • Status changed from new to assigned

comment:2 Changed 3 years ago by jeremyhu@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce this with current bits. I just setup XQuartz to fullscreen mode. I then ran 'xterm' from Terminal.app. XQuartz launched, entered fullscreen mode, and accepted input when I typed.

comment:3 Changed 7 months ago by marco@…

This does not work right for me using xquartz 2.7.5. When I go back and forth between full screen my xterm loses focus and I have to click the darn thing.

Note: See TracTickets for help on using tickets.