Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#544 closed crash (Fixed)

Crash of 2.7.1_rc3

Reported by: thierryv@… Owned by: jeremyhu@…
Priority: Blocker Milestone: 2.7.1
Component: quartz-wm Version: dev (master)
Keywords: Cc:

Description

I've just allowed the automatic update to 2.7.1_rc3 to install itself.

Unfortunately, X11 crashes now when loaded. It crashes at soon as my default xterm window comes up.

Feb 11 16:52:01 california defaults[1536]: \nThe domain/default pair of (org.macosforge.xquartz.X11, dpi) does not exist
Feb 11 16:52:01 california org.macosforge.xquartz.startx[1503]: xauth: file /Users/thierryv/.serverauth.1504 does not exist
Feb 11 16:52:01 california org.macosforge.xquartz.startx[1503]:
Feb 11 16:52:05 california org.macosforge.xquartz.startx[1503]: /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1
Feb 11 16:52:05 california org.macosforge.xquartz.startx[1503]: dyld: Symbol not found: _CGSWindowIsVisible
Feb 11 16:52:05 california org.macosforge.xquartz.startx[1503]: Referenced from: /opt/X11/bin/quartz-wm
Feb 11 16:52:05 california org.macosforge.xquartz.startx[1503]: Expected in: flat namespace
Feb 11 16:52:05 california org.macosforge.xquartz.startx[1503]: in /opt/X11/bin/quartz-wm
Feb 11 16:52:10 california org.macosforge.xquartz.startx[1503]: /opt/X11/bin/xinit: connection to X server lost
Feb 11 16:52:10 california org.macosforge.xquartz.startx[1503]: M
Feb 11 16:52:10 california ReportCrash[1665]: Saved crash report for quartz-wm[1663] version ??? (???) to /Users/thierryv/Library/Logs/DiagnosticReports/quartz-wm_2012-02-11-165210_california.crash
Feb 11 16:52:11 california org.macosforge.xquartz.startx[1503]: waiting for X server to shut down

Attachments (2)

quartz-wm_2012-02-11-165210_california.crash (19.9 KB) - added by thierryv@… 3 years ago.
Crashreported log
quartz-wm_2012-02-11-074927_phoenix-mini.crash (19.9 KB) - added by macosforge@… 3 years ago.

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by thierryv@…

Crashreported log

Changed 3 years ago by macosforge@…

comment:1 Changed 3 years ago by macosforge@…

I am also experiencing this crash after auto-updating.

comment:2 Changed 3 years ago by thierryv@…

More details .....

As posted by Gabriel Phoenix, launchd respawns it. I've disabled "Open at Login" though.

Must closed my user session to stop this cycle.

Tried too to delete /tmp/.X11-unix

No success.

I hope this time I can revert to rc2 ... I was the unlucky one who reported bug #532 (can't revert to previous build).

Hope you can fix this soon.
Regards,
Thierry

Feb 11 17:05:38 california ReportCrash[3069]: Saved crash report for quartz-wm[3864] version ??? (???) to /Users/thierryv/Library/Logs/DiagnosticReports/quartz-wm_2012-02-11-170538_california.crash
Feb 11 17:05:39 california org.macosforge.xquartz.startx[3710]: waiting for X server to shut down
Feb 11 17:05:39: --- last message repeated 1 time ---
Feb 11 17:05:39 california com.apple.launchd.peruser.501[1425] (org.macosforge.xquartz.startx): Throttling respawn: Will start in 7 seconds
Feb 11 17:05:46 california defaults[3907]: \nThe domain/default pair of (org.macosforge.xquartz.X11, dpi) does not exist
Feb 11 17:05:46 california org.macosforge.xquartz.startx[3878]: xauth: file /Users/thierryv/.serverauth.3879 does not exist
Feb 11 17:05:46 california org.macosforge.xquartz.startx[3878]:
Feb 11 17:05:46 california org.macosforge.xquartz.X11.stub[3949]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Feb 11 17:05:46 california org.macosforge.xquartz.X11.stub[3954]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly
Feb 11 17:05:48 california org.macosforge.xquartz.startx[3878]: /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1
Feb 11 17:05:48 california org.macosforge.xquartz.startx[3878]: dyld: Symbol not found: _CGSWindowIsVisible
Feb 11 17:05:48 california org.macosforge.xquartz.startx[3878]: Referenced from: /opt/X11/bin/quartz-wm
Feb 11 17:05:48 california org.macosforge.xquartz.startx[3878]: Expected in: flat namespace
Feb 11 17:05:48 california org.macosforge.xquartz.startx[3878]: in /opt/X11/bin/quartz-wm
Feb 11 17:05:49 california org.macosforge.xquartz.startx[3878]: /opt/X11/bin/xinit: connection to X server lost
Feb 11 17:05:49 california org.macosforge.xquartz.startx[3878]: M
Feb 11 17:05:49 california ReportCrash[3069]: Saved crash report for quartz-wm[4032] version ??? (???) to /Users/thierryv/Library/Logs/DiagnosticReports/quartz-wm_2012-02-11-170549_california.crash
Feb 11 17:05:50 california org.macosforge.xquartz.startx[3878]: waiting for X server to shut down
Feb 11 17:05:50: --- last message repeated 1 time ---
Feb 11 17:05:50 california com.apple.launchd.peruser.501[1425] (org.macosforge.xquartz.startx): Throttling respawn: Will start in 7 seconds
Feb 11 17:05:57 california defaults[4068]: \nThe domain/default pair of (org.macosforge.xquartz.X11, dpi) does not exist
Feb 11 17:05:57 california org.macosforge.xquartz.startx[4039]: xauth: file /Users/thierryv/.serverauth.4040 does not exist
Feb 11 17:05:57 california org.macosforge.xquartz.startx[4039]:
Feb 11 17:05:57 california org.macosforge.xquartz.X11.stub[4183]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Feb 11 17:05:57 california org.macosforge.xquartz.X11.stub[4184]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly
Feb 11 17:05:59 california org.macosforge.xquartz.startx[4039]:
M
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: waiting for X server to begin accepting connections
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: waiting for X server to begin accepting connections /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: waiting for X server to begin accepting connections dyld: Symbol not found: _CGSWindowIsVisible
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: Referenced from: /opt/X11/bin/quartz-wm
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: Expected in: flat namespace
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: in /opt/X11/bin/quartz-wm
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: waiting for X server to begin accepting connections /opt/X11/bin/xinit: connection to X server lost
Feb 11 17:06:01 california org.macosforge.xquartz.startx[4039]: M
Feb 11 17:06:01 california ReportCrash[4196]: Saved crash report for quartz-wm[4194] version ??? (???) to /Users/thierryv/Library/Logs/DiagnosticReports/quartz-wm_2012-02-11-170601_california.crash
Feb 11 17:06:02 california org.macosforge.xquartz.startx[4039]: waiting for X server to shut down
Feb 11 17:06:02: --- last message repeated 1 time ---
Feb 11 17:06:02 california com.apple.launchd.peruser.501[1425] (org.macosforge.xquartz.startx): Throttling respawn: Will start in 5 seconds
Feb 11 17:06:08 california defaults[4228]: \nThe domain/default pair of (org.macosforge.xquartz.X11, dpi) does not exist
Feb 11 17:06:08 california org.macosforge.xquartz.startx[4199]: xauth: file /Users/thierryv/.serverauth.4200 does not exist
Feb 11 17:06:09 california org.macosforge.xquartz.startx[4199]:

comment:3 Changed 3 years ago by strozzi2@…

Hi,

I am having a similar problem. I was just asked to install rc3, and did. While installed, toward the end, it took a while to get through an item like "running package scripts." Anyway it ran. I start Xquartz, I get an xterm, which has its title bar too high (underneath the mac menu bar). I can even type in it, do ls and cd, and even use the X11 mac menu, but after several seconds X quits. I rebooted, and get the same thing.

So this is somewhat reproducible.

By the way, I use X almost every day, and the folks who write it deserve a lot of kudos! My colleagues w/ windows are always having way fun issues w/ their various X servers...

comment:4 follow-up: Changed 3 years ago by macosforge@…

Strozzi2, that's exactly how it happened for me too.

According to the crashlog, apparently it has something to do with quartz-wm? Possibly because of what was changed for bug #538?

Here's something weird though: I just tried to downgrade to rc2 (which was working fine). Downloaded rc2, installed, OK. Launched, and everything is working BUT! in About it says I'm still running rc3. But it's working...

comment:5 in reply to: ↑ 4 Changed 3 years ago by thierryv@…

Replying to macosforge@…:

...

Here's something weird though: I just tried to downgrade to rc2 (which was working fine). Downloaded rc2, installed, OK. Launched, and everything is working BUT! in About it says I'm still running rc3. But it's working...

Then, the bug #538 I've reported with rc1 is still unsolved. At least, it looks like X11.bin is not causing the crash of rc3 ... because even when reverting to rc2, X11.bin of rc3 is not replaced by the one of rc2.

I'll be waiting for the end of the week-end to see if there is a way to manually fix rc3 before to (try) reverting to rc2.

Thanks,
Thierry

comment:6 Changed 3 years ago by jeremyhu@…

  • Milestone set to 2.7.1
  • Resolution set to fixed
  • Status changed from new to closed
  • Version set to dev (master)

Fixed in rc4. Sorry about that.

This is actually unrelated to #538.

comment:7 Changed 3 years ago by jeremyhu@…

  • Component changed from X11.pkg to quartz-wm
  • Priority changed from Not Set to Blocker

comment:8 Changed 3 years ago by thierryv@…

Confirmed: It's fixed for me.
Thanks you. I'll be able to get back to work on Monday.

Thanks a lot too for the good work on X11.
Thierry

comment:9 Changed 3 years ago by strozzi2@…

Yes! rc4 works for me too! Thanks for the fast response - and on a weekend!

comment:10 follow-up: Changed 3 years ago by szepesva@…

Btw, the link on page http://xquartz.macosforge.org/trac/wiki/X112.7.1 to the 2.7.1 version is broken.
It would be good to include a link to http://static.macosforge.org/xquartz/downloads/SL/ for people who fell victim of this bug (like me).
Now, fingers crossed while installing rc4:) I would need to run X11 tomorrow in my class:)

comment:11 in reply to: ↑ 10 Changed 3 years ago by szepesva@…

Replying to szepesva@…:

Btw, the link on page http://xquartz.macosforge.org/trac/wiki/X112.7.1 to the 2.7.1 version is broken.
It would be good to include a link to http://static.macosforge.org/xquartz/downloads/SL/ for people who fell victim of this bug (like me).
Now, fingers crossed while installing rc4:) I would need to run X11 tomorrow in my class:)

rc4 started fine. thanks for the quick fix!

Note: See TracTickets for help on using tickets.